Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battle Tanks 8.61d - Patch 1.24
#1
Hi guys,
this is a special version of Battle Tanks. As some of you already noticed, the next Warcraft 3 patch features some changes of the Wc3 programming language, which will effectively make a lot of maps not playable anymore, when the patch is out. This also affects BT.

There already is a possibility of testing the new patch. When connecting to the Battle.Net, don't choose your regular realm, but the realm 'Westfall'. When doing so, the new patch will be installed. When connecting again to one of the other realms, the old version (1.23) will be installed again.

Using the new patch, I made a 1.24-compatible version of BT 8.61c and called it 8.61d. There are no differences beside the compatibility fix.

Although I don't expect any problems because of this (only three lines of code had to be changed), it would be nice, if some of you guys could test this map. This way we can make sure, that there will be no problems, when the actual patch will be released.
This post has been brought to you by Sand - it's everywhere, get used to it.
Reply
#2
I tried it and seem that it doesnt work.
i downloaded the new patch and tried to host a game, but when i try to host btanks its says (german) "Das Spiel konnte nicht gefunden werden". other random maps i can host.
i tried to make a singleplayer match, but the game doesnt show any playerslots for battletanks (old and new) and when i try to start the game the board (or what ever it is (the background)) goes up and comes down again with the same content.
Anti-HighBounty Alliance has wonBig Grin
[Image: btanksia6.jpg]
Reply
#3
i only tried to host it in westfall online.
it says "Das Spiel konnte nicht gefunden werden."
i did not tried it in singleplayer or lan yet.
Reply
#4
Hm, it worked at least in singleplayer for me. Maybe it's because of the map optimization tool. I'll check that again.

EDIT: Yep, that was it. Please try again. And also delete the old map, since the new one has exactly the same name.
This post has been brought to you by Sand - it's everywhere, get used to it.
Reply
#5
The problem that the players arent shown is if the Map Optimizer isnt compatible with the wc3 patch u got. Foor this they first need to upgrade it for 1.24
Weltuntergang. Na und?
Die Sonne geht doch auch jeden Tag unter.
Reply
#6
its working now
gj Big Grin
Anti-HighBounty Alliance has wonBig Grin
[Image: btanksia6.jpg]
Reply
#7
works now
Reply
#8
It DOES NOT work on Europe Gateway at this moment!
I was disconnected from battle.net while playing then i reconnected and autodownloaded the new wc3 patch 1.24.
i cant play any btanks game, no matter if c or d version
Reply
#9
I know, Blizzard screwed this one up.

They changed something, this is not the same patch, as the one on Westfall. I had to rewrite one function, because of some bug they now introduced and right now I get random crashes, when playing the map. It's unplayable right now. Seriously, Blizzard just fucked this patch up.
This post has been brought to you by Sand - it's everywhere, get used to it.
Reply
#10
It really sucks not being able to play Battle Tanks.

One positive thing though, nobody is playing DotA right now.
Reply
#11
O_o Hive boss chieftan!

Hi Ralle! Surprise to see you posting hereSmile



Exodus is working to find a solution to solve this. Maybe we see a new version tonight or tomorrow. Currently my bt mod isn't affected from 1.24 patch. 7.55 version and older does work. But I haven't checked on 8.xx versions yet....

At some point the Battle Tanks script was optimized in a 8.xx version (I don't know which) and is one of the reasons this affects battle tanks.
Reply
#12
Well I'm not some expert programmer, but I think I've got a pretty good handle on these false positives. I already fixed Civ Wars to work with it. If you need a hand, I'm willing to help.
Reply
#13
Terrabull Wrote:Well I'm not some expert programmer, but I think I've got a pretty good handle on these false positives. I already fixed Civ Wars to work with it. If you need a hand, I'm willing to help.
Are you talking about those weird If-functions? Also, do you refer to compile errors or Warcraft crashes? Because I can compile the map with the new patch, it's just that it crashes at a lot of places.
The weird thing is, that the crashes are somehow related to the creep upgrades. When those are at least level 1, I get crashes. But they happen in functions that don't have anything to do with upgrades. Right now I'm not sure if it's worth the time trying to fix, what Blizzard destroyed or just wait for a new patch.

But still, thanks for the offering.
This post has been brought to you by Sand - it's everywhere, get used to it.
Reply
#14
5.62 ENG works, but nothing newer than that, including 8.61D. I was all excited about trying the HCL code today and flipping Blizzard has to drop this rotten goose egg on us. This is what the 10th update that adds no real functionality to the ancient bnet code.
Btanks fan since version 4US
I don't know why it happened by I can fix it!
Reply
#15
Icono Wrote:5.62 ENG works, but nothing newer than that, including 8.61D. I was all excited about trying the HCL code today and flipping Blizzard has to drop this rotten goose egg on us. This is what the 10th update that adds no real functionality to the ancient bnet code.

Gonna try that now - Oldschool FTW.

PS: 4.2 works too I think.
Reply
#16
Since IceFrog seems to have more information about this situation, as us puny mortals, I'll quote a post of his.

Source: http://www.playdota.com/forums/14932/1-2...post196178

IceFrog Wrote:There have been a lot of questions about 1.24 and DotA, so I'm going to take the time here to answer them.

A new warcraft patch has been released with the focus on fixing a bug that could cause you to get a virus when joining a game. As a result of this, some core Warcraft 3 functions that are used in DotA and most other maps had to be removed. To make up for the significant loss in functionality, new replacement functions were also added to the patch.

Some confusion comes from the fact that some maps like 6.59d work under 1.24. This is only partially true. There is nothing special about those maps, 1.24 is configured to run some maps in temporary 1.23 compatibility mode while 1.24 is further developed. The patch has not been properly configured to run 6.61b in this mode, so 6.61c will be released. That map has no changes except the version string.

As a result of the function changes, maps are not cross compatible between 1.24 and pre-1.24. A lot of code in has to be rewritten for maps to become compatible with 1.24. The next version of DotA (6.62) has all of its code updated to follow the 1.24 requirements.

As of right now, 1.24 still has various bugs in it's functions that prevent most 1.24 maps from running properly on it. As these issues get fixed in coming 1.24b/1.24c patches, 6.62 beta will be updated alongside them. As soon as the new patch is stable and 6.62 is tested on it sufficiently, it will be released. Hopefully the map will return to a stable code state in the very near future.

Once the 6.62/1.24 situation is over, regular map development will resume. The versions that follow it will most likely focus primarily on balance improvements and performance tweaks.

For people that cannot easily do multiple patch upgrades (net cafes for example), I recommend you wait until 1.24b/c is released before undergoing that effort.

If something isn't clear, feel free to PM me and I'll try to answer it.
This post has been brought to you by Sand - it's everywhere, get used to it.
Reply
#17
Yes, 5.62 is working fine. Back to the rootsWink

Someone tested maps after 5.62 if they are working? Perhaps there is a newer version to play in the meantime?
Northrend: Proud shaman of Clan BuG.
Azeroth: Proud shaman of Clan BTOW.

Don`t be afraid - be happy!
Reply
#18
I just released a beta version for our beta team, that seems to work.

This version also includes some of the changes for next version, which needed more testing, but they are also now in this version. I think I can release the final version tomorrow if everything works out, although this version is still kinda unfinished. But I guess everything is better, than nothing ;)
This post has been brought to you by Sand - it's everywhere, get used to it.
Reply
#19
http://www.wc3c.net/showpost.php?p=10971...tcount=368
Reply
#20
ive been doing some digging ive gotten 8.14 to work so thats better than 5.24 atleast will update on whether i find others from the 8.0 series Well ive been through all the 8.0 series and 8.14 seems to be the only one thats working under the new patch so in the mean time we can enjoy some earlier battle tanks while the Great Exodus and Bob666 get the new one up and running
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Battle Tanks 8.80c Exodus 21 15,617 2015-08-09, 21:11:11
Last Post: AeroniumX
  Battle Tanks 8.63 Hacked and Mangled Mod by NarFlux Exodus 2 2,986 2014-04-22, 13:42:22
Last Post: omefisto
  New Battle Tanks Homepage! Exodus 8 7,911 2014-02-23, 18:59:08
Last Post: BtankNoob
  Suggestions for next patch (8.80) psycodiver 3 2,536 2014-02-11, 16:55:52
Last Post: GodStrongArms
  Battle Tanks 8.79d Exodus 10 8,306 2014-01-08, 20:48:46
Last Post: Exodus



Users browsing this thread: 2 Guest(s)