Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BattleTanks 8.80 not editable :S
Hey everybody, I hope this thread is at the right place, im new in this forum so excuse me if iit`s not right here !Tongue
Okay, now to my question: if I edit the 8.67 Battle Tanks map everything works fine, i was able to create new shops &buildings, I already created some new Tanks (some based on old Tanks, like Demon Tank 2.0, more tankier, bigger and stronger abilities) and i can create new weapons. But then i wanted to edit the 8.80 Map, because there is already a lot work done, so I added a new Tank and a new weapon. Then I wanted to test them, if they work and the Tooltips are working, but when i tried to start the map, I wasn't able to get it working,  it looks like it starts, but then the Options like bots etc. come back down, if you know what i mean, so i can't go ingame :c Now i wanted to ask, where my mistake is, or if it`s protectet so I destroy the map with editing? Already thank you for your answers !Big Grin 

P.S.: Actually it's boring to make the map while sitting alone in my room with my PC , so if sb. wants to work with me (prefered a German)  together on one map, just pm me and we can exchange Skype Informations or smth. like that :D
Well, I guess you made sure, that you used the Open Source version, right? ;)

Other than that, there can actually be a lot of possibilities for this. The last time I encountered this problem, the problem was the map file name! Wc3 uses some arcane max file name length. So if the path were the map is placed and the name of the map file name combined are too long, Wc3 will return to the game lobby, after trying to load the game. So maybe try to place the map somewhere else or try to give it a shorter name (not the name ingame, but the name of the file in your operating system).

If that does not work, well ... then it gets more difficult.
This post has been brought to you by Sand - it's everywhere, get used to it.
Just to be sure, i got the map here Is this the Open source map? Or am i stupidConfused ?
Does the original version load?
(2016-10-22, 23:18:17)RaptorXI Wrote: Does the original version load?

Yes, as long as i don't edit the map the map works!
Try to rename and save (dont use "save as"). If it still doesn't load you should change your settings.
Okay, i tried it, but the map is still not workingConfused It's not working on the latest wc3 patch and not on the cracked version... Can u maybe send me your map if its working after editing ? Or can you just tell me if thgats the download link? Well, i hope ill get it working, caz on the 8.63 map there is not that much stuff like on 8.80Big Grin Thank you for your answersBig Grin
We could be having a similar problem.  I, too, am unable to run my revised copy of the 880c unprotected map.

When I attempt to save it, I am assaulted with a slew of script errors reported by the Frozen Throne World Editor.  
First, it complains that none of the triggers have an InitTrig_Trigger_Name function, and so it requires that each such trigger be disabled.  
Then, it tells me that there are over 260,000 other errors in the JASS script.  I may be exaggerating by a power of ten there, but it is a large number.  
The map does get saved — I see all my changes if I re-open it, — but it is inoperable.

I don't know why that would prevent the map from even appearing in Custom Game menu's list, but something is wrong.

I've been searching the web for similar problems with other maps, but I haven't discovered anything yet.
It isn't a problem with my edition of WC3 — 1.26, — nor is it the limited length of path to the map being exceeded — 48 text characters, and mine is much shorter.
Well, that sounds like you are using only the standard Wc3 editor. The map was made using vJass, so you need some additions.

You can either use the Jass NewGen Pack (JNGP) or the Wex Editor (SharpCraft World Editor Extended Bundle). You can find both of them there:
This post has been brought to you by Sand - it's everywhere, get used to it.
Yep, thanks for the advice.  I suspected that you guys were using a different editors.  
I eventually settled on simply using an MPQ editor to extract and repack the pieces which I needed to edit.

As to the original problem, Infernal-Robot-Fan, my map did eventually appear.  Probably all which happened was that I miscounted by 1, or so, the length of the entire pathname in the Maps/ folder.  It is also possible that an invalid MPQ was made as a result of editing; this happened to me at least once when i used the MPQ editor's Compact function.

Battle Tanks CnF is in service and working well.
Hey guys, after a long time I decided to give the mapping in Warcraft 3 another try. When i began, the JNGP didn't worked with the updated version of the worldeditor, so i decided to swap to the other option Exodus mentioned, the Wex Editor. But once again i have a problem with it. I tried to troubleshoot atleast a littel bit, and i figured out why the map isn't shown ingame, the pjass.exe and the Jesshelper weren't working so i had to run them manually and uncheck the ''ask before open this file'', so i atleast have a real error report when i try to save the Map. So i atleast know now, that theres something wrong. When i try to save the map ( no matter if i actually change something)  everything seems good to the point where Jasshelper says ''Structs writing'', then it tells me there is a pjass error. it opens a Window then titled Syntax Errors where it says that it finds 15 compile errors, they all say that there is a variable uninitialised like angleZsin,angleZCos and min DistNr so it seems like it is something with camera settings, but I'm a Noob in programming so I'm not sure. The thing that confuses me is, that this only happens in the 8.80c version, not in the 8.63 (I am 100% sure that both are open source and the right files, both show up ingame as open source before modding, afterwards the 8.63 works fine, the 8.80c shows up but there is no option to fill the slots with bots/start the game). After saving the Editor jsut says ''Unable to save the map'' and then continues letting me edit it, but when i close the editor then, the map is a little bit smallre then before, normally its 2457 KB, afterwards 2427KB, so there is something missing.. I hope anyone has an idea what could cause this problem, if needed i can upload a video/screenshots of the process  saving so you can see detailed what happens, but maybe anyone already expirienced something like this and know a quick fixSmile Anyway, thank you for every help you can offer ^-^ 

   here you can see some of the Errors:         

Edit: Hmm, i went to the official discord today and downloaded the 9.00 beta wich is also unprotected.. this version works just fine, since it contains als the things 8.80c contains its fine, looks like there was something wrong with the 8.80c...Smile
Sorry, just saw this.

It's that you got it to work. But just to say how you can fix the uninitialized error:

When it says that a variable is uninitialized, you need to give it a value before it is used in any calculations. For example, it says that "angle" is uninitialized:

local real angle

To fix it, just give it a value (usually it's not important which value it is), like this:

local real angle = 0.0

This fixes this error.
This post has been brought to you by Sand - it's everywhere, get used to it.

Users browsing this thread: 1 Guest(s)